database.sarang.net
UserID
Passwd
Database
DBMS
MySQL
ㆍPostgreSQL
Firebird
Oracle
Informix
Sybase
MS-SQL
DB2
Cache
CUBRID
LDAP
ALTIBASE
Tibero
DB 문서들
스터디
Community
공지사항
자유게시판
구인|구직
DSN 갤러리
도움주신분들
Admin
운영게시판
최근게시물
PostgreSQL Q&A 9773 게시물 읽기
No. 9773
configure: error: library 'xml2' (version >= 2.6.23) is required for XML support
작성자
전상도(sebul)
작성일
2017-03-05 06:01:58
조회수
1,106

https://www.postgresql.org/docs/9.6/static/datatype-xml.html 를 보고

/configure --with-libxml

했더니

configure: error: library 'xml2' (version >= 2.6.23) is required for XML support

나오네요. 어떻게 하나요?

이 글에 대한 댓글이 총 3건 있습니다.

서버에 libxml2가 설치되어있는지 확인하시고

version이 2.6.23 이상으로 설치되어있는지 확인하셔야겠죠..

김주왕(kimjuking)님이 2017-03-06 08:44:50에 작성한 댓글입니다.

RedHat 계열 OS를 사용하고 있거나, ubuntu 계열이면, libxml 패키지에 대한 -devel 패키지도 함께 설치하셔야 합니다.

김상기(ioseph)님이 2017-03-06 09:32:36에 작성한 댓글입니다.

sudo apt-get install libxml2-dev
 

전상도(sebul)님이 2017-03-07 04:12:19에 작성한 댓글입니다.
[Top]
No.
제목
작성자
작성일
조회
9776row_number 사용시 성능 개선 방법 [4]
비투즈
2017-03-23
900
9775pg_catalog."C" 에 대한 질문 드립니다 [1]
황성근
2017-03-21
836
9774client의 ip address 를 가져올수 있는 방법이 있나요? [1]
김경태
2017-03-05
1008
9773configure: error: library 'xml2' (version >= 2.6.23) is required for XML support [3]
전상도
2017-03-05
1106
9772postgresql 9.6 번역 참여 방법? [1]
전상도
2017-03-01
1052
9771Windows용 PostgreSQL에서 대용량 데이터 Insert 작업할때 사용하던 Disk용량이 없을때 문제 [2]
김용준
2017-02-25
1039
9769run파일로 설치 할 경우 [2]
김세윤
2017-02-17
1034
Valid XHTML 1.0!
All about the DATABASE... Copyleft 1999-2017 DSN, All rights reserved.
작업시간: 0.143초, 이곳 서비스는
	PostgreSQL v9.6.3으로 자료를 관리합니다