database.sarang.net
UserID
Passwd
Database
DBMS
MySQL
PostgreSQL
Firebird
Oracle
Informix
Sybase
MS-SQL
DB2
Cache
CUBRID
ㆍLDAP
ALTIBASE
Tibero
DB 문서들
스터디
Community
공지사항
자유게시판
구인|구직
DSN 갤러리
도움주신분들
Admin
운영게시판
최근게시물
LDAP Q&A 2175 게시물 읽기
No. 2175
openldap-2.3.4 에서 make test시에 오류입니다.
작성자
백성민
작성일
2005-06-27 18:59
조회수
7,380

먼저 openldap를 설치하기 전에 openssl-0.9.7g 과 Berkerly DB-4.2 를 설치했습니다.

openldap-2.3.4 설정옵션은 다음과 같습니다.

make test까지 일반계정으로 설치를 하였습니다.

 

CPPFLAGS="-I/usr/local/BerkeleyDB.4.2/include \
-I/usr/local/ssl/include/openssl \
-I/usr/local/include" \
LDFLAGS="-L/usr/local/BerkeleyDB.4.2/lib -L/usr/local/ssl/lib \
-L/usr/local/lib" \
./configure --prefix=/usr/local/openldap --with-tls --enable-slurpd \
--enable-crypt \
--enable-syslog \
--sysconfdir=/etc

 

make depend

make

make test

make test시에 나타나는 오류는 다음과 같습니다.

[ hoopy@ns openldap-2.3.4]$ make test

cd tests; make test

make[1]: Entering directory `/home/hoopy/openldap-2.3.4/tests'

make[2]: Entering directory `/home/hoopy/openldap-2.3.4/tests'

Initiating LDAP tests for BDB...

Cleaning up test run directory leftover from previous run.

Running ./scripts/all...

>>>>> Executing all LDAP tests for bdb

>>>>> Starting test000-rootdse ...

running defines.sh

Starting slapd on TCP/IP port 9011...

Using ldapsearch to retrieve the root DSE...

Waiting 5 seconds for slapd to start...

Waiting 5 seconds for slapd to start...

Waiting 5 seconds for slapd to start...

Waiting 5 seconds for slapd to start...

Waiting 5 seconds for slapd to start...

Waiting 5 seconds for slapd to start...

./scripts/test000-rootdse: line 61: kill: (31370) - 그런 프로세스가 없음

ldap_bind: Can't contact LDAP server (-1)

>>>>> Test failed

>>>>> ./scripts/test000-rootdse failed (exit 1)

make[2]: *** [bdb-yes] 오류 1

make[2]: Leaving directory `/home/hoopy/openldap-2.3.4/tests'

make[1]: *** [test] 오류 2

make[1]: Leaving directory `/home/hoopy/openldap-2.3.4/tests'

make: *** [test] 오류

 

오류가 난 파일의 로그를 다음과 같이 확인하였습니다.

 

@(#) $OpenLDAP: slapd 2.3.4 (Jun 27 2005 13:17:55) $
root@ns:/home/hoopy/openldap-2.3.4/servers/slapd
daemon_init: ldap://localhost:9011/
daemon_init: listen on ldap://localhost:9011/
daemon_init: 1 listeners to open...
ldap_url_parse_ext(ldap://localhost:9011/)
daemon: initialized ldap://localhost:9011/
daemon_init: 1 listeners opened
slapd init: initiated server.
slap_sasl_init: SASL library version mismatch: expected 2.1.21, got 2.1.19
slapd destroy: freeing system resources.
slapd stopped.
connections_destroy: nothing to destroy.

아직 ldap에 대해서 개념이 잘 안잡히는지라..위의 오류점 해석점 부탁드리겠습니다.

감사합니다.

 

이 글에 대한 댓글이 총 2건 있습니다.

자답입니다.

문제는 cyrus-sasl-2.1.19 버전을 요구하고있네요.

저는 cyrus-sasl-2.1.20 버전을 설치했었는데.. 그밑에 버전으로 설치를 해야하는군요.

 

openldap-2.2.26  버전으로 다시 설치했습니다.

openldap를 설치하기 전에

openssl-0.9.7g

cyrus-sasl-2.1.19

BerkeleyDB.4.2 설치를 요구하고 있네요.

 

백성민님이 2005-06-29 12:40에 작성한 댓글입니다. Edit

감사합니다. 답변까지 달아 주시니 좋네요

ㅋㅋㅋ

송상준(sjsong)님이 2005-06-30 00:31에 작성한 댓글입니다.
[Top]
No.
제목
작성자
작성일
조회
2178opelLdap 설치 시 이런 에라가..고수님들 좀 봐 주세욤 ㅡ.ㅡ [1]
왕초보
2005-07-05
6729
2177Domino Notes 에서 AD로 이전에 관해서 [2]
최성민
2005-06-30
6831
2176ldapadd 에서 문제입니다.. 핼프미~ [1]
백성민
2005-06-30
7071
2175openldap-2.3.4 에서 make test시에 오류입니다. [2]
백성민
2005-06-27
7380
2174AD의 계정으로 리눅스 웹서버 로그인 [6]
시저
2005-06-22
7682
2173sun on ldap 에서의 트랜잭션처리는 어떻게 하나요? [1]
오종목
2005-06-09
6832
2170kerberos SSO
야옹이
2005-05-05
7351
Valid XHTML 1.0!
All about the DATABASE... Copyleft 1999-2021 DSN, All rights reserved.
작업시간: 0.013초, 이곳 서비스는
	PostgreSQL v13.3으로 자료를 관리합니다