database.sarang.net
UserID
Passwd
Database
DBMS
ㆍMySQL
PostgreSQL
Firebird
Oracle
Informix
Sybase
MS-SQL
DB2
Cache
CUBRID
LDAP
ALTIBASE
Tibero
DB 문서들
스터디
Community
공지사항
자유게시판
구인|구직
DSN 갤러리
도움주신분들
Admin
운영게시판
최근게시물
MySQL Q&A 31359 게시물 읽기
No. 31359
mysql with 버전 오류 문의 드립니다.
작성자
정동호(업티즌)
작성일
2022-02-07 11:34
조회수
1,969

select version();

>> 5.7.36-google-log


WITH p1 AS (

SELECT '111' as arg1 from dual

)

select * from p1

;


ERROR 1064 : You have an error in your SQL syntax;

check the manual that corresponds to your MySQL server

version for the right syntax to use near 'P1 AS (

select '121' AS arg1 from DUAL) 

select * from p1' at line 1


많은 도움 받고 있는데요. mysql 관련 with 명령 안되는것

같아서요. 버젼 때문인지 문의 드립니다.

이 글에 대한 댓글이 총 2건 있습니다.

mysql 8.0 버전부터 가능합니다~

정상규(pajama)님이 2022-02-07 13:20에 작성한 댓글입니다.

네. 확인 감사드립니다. ~~

정동호(업티즌)님이 2022-02-07 13:34에 작성한 댓글입니다.
[Top]
No.
제목
작성자
작성일
조회
31363두 개의 SELECT 결과를 비교하여 유일한 값을 가져오는 방법 [4]
김현석
2022-04-05
1631
31361특정 필드 기준으로 각 필드의 합을 구하는 방법 [4]
규야
2022-03-24
1630
31360필드내 구분자로 들어가 있는 데이터 select 하는 방법 문의 [4]
조현철
2022-02-27
1875
31359mysql with 버전 오류 문의 드립니다. [2]
정동호
2022-02-07
1969
31358구축한 웹사이트에서 mysql과 php 연동 문제 [2]
김길동
2022-01-28
2176
31357세가지 기준의 기간별 통계 SQL 문의 드립니다. [1]
papa
2021-12-23
2807
31356통계 쿼리 질문합니다. [1]
김동현
2021-12-20
2779
Valid XHTML 1.0!
All about the DATABASE... Copyleft 1999-2022 DSN, All rights reserved.
작업시간: 0.064초, 이곳 서비스는
	PostgreSQL v14.2로 자료를 관리합니다