database.sarang.net
UserID
Passwd
Database
DBMS
MySQL
PostgreSQL
Firebird
Oracle
Informix
ㆍSybase
MS-SQL
DB2
Cache
CUBRID
LDAP
ALTIBASE
Tibero
DB 문서들
스터디
Community
공지사항
자유게시판
구인|구직
DSN 갤러리
도움주신분들
Admin
운영게시판
최근게시물
Sybase Q&A 4399 게시물 읽기
No. 4399
전자정부프레임워크 + Sybase 쓰는데 JDBC이용해서 DB 접속이 안됩니다 ㅠㅠ
작성자
최세원
작성일
2014-09-11 13:24
조회수
6,400

안녕하세요

전자정부 프레임워크에 sybase 붙여서 쓰려구 하는데요

기존에 쓰는 티베로랑 오라클은 DB접속이 되서 쿼리가 조회잘 되는데

sybase가 안되서 이렇게 글을 남깁니다 ㅠ

 

소스는 context-datasource.xml

--잘됨  

<bean id="dataSource" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">
   <property name="driverClassName" value="net.sf.log4jdbc.DriverSpy"/>
   <property name="url" value="jdbc:log4jdbc:tibero:thin:@10.184.77.52:8629:tibero2" />
   <property name="username" value="UBCREOWN" />
   <property name="password" value="554YTT23" />
 </bean>
  

-- 안됨 ㅠㅠ
   <bean id="sybaseTest" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">
   <property name="driverClassName" value="com.sybase.jdbc2.jdbc.SybDriver"/>
   <property name="url" value="jdbc:sybase:Tds:10.22.4.11:2638/EBAIDW" />
   <property name="username" value="DWMGR" />
   <property name="password" value="DWMGR" />
 </bean>

이렇게 jar 파일을 받아서 라이브러리에 넣고 sybase 접속정보를 맞게 코딩한것 같은데 안되네요 ㅠㅠ

아시는분들 답변좀 부탁드립니다 !

이 글에 대한 댓글이 총 1건 있습니다.

SYBASE도 잘 됩니다. 자료가 없어서 맨바닥에 헤딩해가면서 해야 그렇지... 

ASE, IQ 모두 전자정부프레임워크에 잘 붙습니다. 

 

암튼...

DB명을 보니 IQ로 보여지네요. 

IQ 버전이 12.6 버전 이하이신지 확인하는게 우선일 것 같네요.

사용하려는 jdbc 드라이버 버전이 너무 낮아서요....

 

1. IQ버전에 맞는 jcon?.jar 파일을 사용하시길 바랍니다. 

  12.5-12.6 버전을 사용하고 있는 싸이트는 있지만, 개발을 하는 싸이트가 많지 않은 관계로 

  사용하실려는 jdbc드라이버가 IQ버전과 안맞는게 아닌가 하는 의심이 듭니다.

  12.5 - 12.6  jconn2.jar

  12.6 - 12.7  jconn3.jar

  15.x - 15.4  jconn4.jar 

 

2. url property 란에 charset 부분이 없는것 같습니다. 

  최근 2-3년간 기간계 데이터가 utf8인 경우에는 utf8도 많이 늘고 있는 실정입니다만...

  드라이버 버전이 낮고, 통상 국내 IQ 설치시  eucksc charset을 사용하기 때문에... 

바꿔보시길 바랍니다

 

** jconn3.jar jconn4.jar 를 전자정부프레임에 사용한 경험이 있습니다만. jconn2.jar는 없네요.

**안될때는 접속부분만 자바로 만들어서 DB 접속시 나오는 에러 메세지에 대응하면 되었음...

** IQ DB 생성시 JAVA ON 옵션이 없었다면... jdbc 접속이 불가능함.

## 참고 ## jconn4.jar 파일 사용시 charset 보다는
새로생긴 charsetmap 옵션을 사용하는게 좋습니다. 관련문서는 
Sybase 문서 를 참조하면 됩니다.(ASE에 대해서만 기술되어 있습니다만)

소이화님이 2014-09-11 17:27에 작성한 댓글입니다.
이 댓글은 2014-09-12 08:56에 마지막으로 수정되었습니다. Edit
[Top]
No.
제목
작성자
작성일
조회
4402sybase odbc 관련되어 질문 드립니다. [3]
초보개발자
2014-10-15
5841
4401sybase 구동에러 [1]
동주
2014-09-12
4505
4400sybase 구동시 에러 [1]
동주
2014-09-12
4592
4399전자정부프레임워크 + Sybase 쓰는데 JDBC이용해서 DB 접속이 안됩니다 ㅠㅠ [1]
최세원
2014-09-11
6400
4398반복 쿼리 [1]
김한상
2014-09-01
4868
4396서버 복구시 Data(dat)파일 과 master(dat) 을 어찌 올려야하나요? [2]
천영수
2014-07-29
3387
4395pda 윈도우모바일 6.0 에서 Sybase 연결 문의 입니다. [1]
펄링스
2014-07-27
3596
Valid XHTML 1.0!
All about the DATABASE... Copyleft 1999-2021 DSN, All rights reserved.
작업시간: 0.012초, 이곳 서비스는
	PostgreSQL v13.3으로 자료를 관리합니다