database.sarang.net
UserID
Passwd
Database
DBMS
MySQL
ㆍPostgreSQL
Firebird
Oracle
Informix
Sybase
MS-SQL
DB2
Cache
CUBRID
LDAP
ALTIBASE
Tibero
DB 문서들
스터디
Community
공지사항
자유게시판
구인|구직
DSN 갤러리
도움주신분들
Admin
운영게시판
최근게시물
PostgreSQL Q&A 9685 게시물 읽기
No. 9685
PG 설치 시 READLINE 관련 오류 질문입니다.
작성자
NK(NK1)
작성일
2016-07-31 21:47ⓒ
2016-08-01 10:35ⓜ
조회수
7,416

./configure 실행후 아래의 에러가 발생하였습니다.

 

<에러메시지>

configure: using perl 5.10.1

checking for main in -lm... yes

checking for library containing setproctitle... no

checking for library containing dlopen... -ldl

checking for library containing socket... none required

checking for library containing shl_load... no

checking for library containing getopt_long... none required

checking for library containing crypt... -lcrypt

checking for library containing shm_open... -lrt

checking for library containing shm_unlink... none required

checking for library containing fdatasync... none required

checking for library containing sched_yield... none required

checking for library containing gethostbyname_r... none required

checking for library containing shmget... none required

checking for library containing readline... no

configure: error: readline library not found

If you have readline already installed, see config.log for details on the

failure. It is possible the compiler isn't looking

 

 

 

그래서 readline 설치를 버전 한 3가지로 진행하고

 

/usr/local/lib 위치로 가서 라이브러리가 잘 설치 된것을 확인하였습니다 .

 

-rw-r--r--. 1 root root 1101868 2016-08-01 04:56 libreadline.old

-rw-r--r--. 1 root root 160478 2016-08-01 04:56 libhistory.old

-r-xr-xr-x. 1 root root 97215 2016-08-01 04:56 libhistory.so.6.2

lrwxrwxrwx. 1 root root 17 2016-08-01 04:56 libhistory.so.6 -> libhistory.so.6.2

-r-xr-xr-x. 1 root root 628009 2016-08-01 04:56 libreadline.so.6.2

lrwxrwxrwx. 1 root root 18 2016-08-01 04:56 libreadline.so.6 -> libreadline.so.6.2

-rw-r--r--. 1 root root 955476 2016-08-01 04:59 libreadline.a

-rw-r--r--. 1 root root 141498 2016-08-01 04:59 libhistory.a

-rw-r--r--. 1 root root 85145 2016-08-01 04:59 libhistory.so.4.3

lrwxrwxrwx. 1 root root 17 2016-08-01 04:59 libhistory.so.4 -> libhistory.so.4.3

lrwxrwxrwx. 1 root root 17 2016-08-01 04:59 libhistory.so -> libhistory.so.4.3

-rw-r--r--. 1 root root 541185 2016-08-01 04:59 libreadline.so.4.3

lrwxrwxrwx. 1 root root 18 2016-08-01 04:59 libreadline.so.4 -> libreadline.so.4.3

lrwxrwxrwx. 1 root root 18 2016-08-01 04:59 libreadline.so -> libreadline.so.4.3

-rw-r--r--. 1 root root 126318 2016-08-01 05:20 libz.a

-rwxr-xr-x. 1 root root 99184 2016-08-01 05:20 libz.so.1.2.8

lrwxrwxrwx. 1 root root 13 2016-08-01 05:20 libz.so -> libz.so.1.2.8

lrwxrwxrwx. 1 root root 13 2016-08-01 05:20 libz.so.1 -> libz.so.1.2.8

drwxr-xr-x. 2 root root 4096 2016-08-01 05:20 pkgconfig

[postgre@localhost lib]$ pwd

/usr/local/lib

 

 

혹시 경로를 못찾는것같아서

./configure --with-libraries=/usr/local/lib 까지 경로를 주고 다시 실행하였지만,

 

마찬가지로 위와같은 에러가 발생합니다.

 

그래서 그냥 무시하고 ./configure --without -readline 으로 configure 완료하고 make insall 을 했습니다.

 

컴파일 도중 알수없음 이라는 메시지가 많이 나타납니다. 구글링을 해보니 readline 미설치 떄문이라는

 

답변을 보고 좌절하였습니다. .. ㅜㅜ

 

저처럼 설치시 위와같은 오류가 발생한 분 없을까요?

 

* 리눅스6 설치환경이고 pg버전으 9.5.3 입니다.

굳이 소스컴파일 하는 이유는 AIX 설치 대비 설치연습중입니다.

 

 

 

이 글에 대한 댓글이 총 2건 있습니다.

리눅스라면, readline 라이브러리는 OS 배포판에 있는 것(라이브러리와 헤더파일)을 쓰면 특별한 문제없이 사용할 수 있습니다.

 

김상기(ioseph)님이 2016-08-03 22:54에 작성한 댓글입니다.

deb계열이라면

sudo apt-get install libreadline-dev

 

가우님이 2016-08-05 15:18에 작성한 댓글입니다. Edit
[Top]
No.
제목
작성자
작성일
조회
9691worker took too long to start; canceled 오류 [4]
황석준
2016-08-09
8357
9690AIX7.1 에서 PG 컴파일 오류 [2]
NK
2016-08-08
7275
9689PG 파일 시스템 구성 [1]
NK
2016-08-05
7678
9685PG 설치 시 READLINE 관련 오류 질문입니다. [2]
NK
2016-07-31
7416
9684오라클 쿼리를 PGSQL로 변환 [2]
탁구공
2016-07-29
8671
9683postgresql 클로닝을 떳는데요 [1]
서호연
2016-07-28
8333
9682libpq 사용시 물리적 네트워크단선에 대한 처리 방법 문의 [3]
질의
2016-07-27
7430
Valid XHTML 1.0!
All about the DATABASE... Copyleft 1999-2024 DSN, All rights reserved.
작업시간: 0.017초, 이곳 서비스는
	PostgreSQL v16.2로 자료를 관리합니다